Close
Showing results 1 to 10 of 10
  1. #1

    Default First time dedicated GPU.

    Hi Hi.

    So i've always used SLI and generally had no problems. Came back to WoW, everytime I went to Dalaran I would have that GPU stutter for about a minute until it settled- checked HWinfo etc but everything was being grossly underutilized (according to the software).

    I remember one of Mirai's videos where he explained the benefits of having GPUs power a monitor and only that monitor.
    Everything is working wonderfully from a performance perspective.

    I ran the window layout wizard and selected 'Multi-monitor with per-monitor swapping'. Works great (performance wise) except the aspect ratio is off. The main window (single instance on monitor A) is happily running at 1440p yet the alts (all stacked on monitor B) are running as 'custom'. Even if I changed monitor B to 1440p (inside Wow-settings) the mouse repeater doesn't line up.



    No mods, addons etc.
    Attached Images Attached Images

  2. #2

    Default

    ISboxer will set it's positioning based on the Window Layout region sizes, not what you set the game to, which should match the RESET region size for each swap group, and is normally going to be the large region for that swap group.

    But you have three ways to resolve it.
    1. Set the RESET region for Swap Group 2 (the Swap Groups Tab there on the right), to be Region 1. So then all the games will be rendering at the same resolution (that's what the RESET region does).
    2. Create a new region for Swap Group 2, which is the same size as the RESET region for Swap Group 1 (if swap group 1 has no reset region, then the size of Region 1 is what you want). You don't have to assign it as a home window or anything. Just purely needs to be there for sizing purposes.
    3. Under Repeater Profiles -> Default, set the Mouse Cursor Postioning Mode to be one of the Scaled options. Although you are better off with options 1 or 2, because otherwise your game UI scale changes so things can end up positioned slightly differently.

  3. #3
    Multiboxologist MiRai's Avatar
    Join Date
    Apr 2009
    Location
    Winter Is Coming
    Posts
    6352

    Default

    While changing the Reset regions would fix the problem, wouldn't that just distort the game windows since they're two different sizes?

    Personally, I think the best way to fix this, is to simply change Region 1 to be the size of Region 2.
    Do not send me a PM if what you want to talk about isn't absolutely private.
    Ask your questions on the forum where others can also benefit from the information.

    Author of the almost unknown and heavily neglected blog: Multiboxology

  4. #4

    Default

    I chose option 1!

    While it does distort my alts a little bit, it's all good with me since I run them at render scale 50% anyway.
    Thank you both for your help

    HAPPY MULTIBOXING! xx

  5. #5

    Default

    Ever since BFA I have been having trouble with this and I believe it's due to the silly 'auto detect' gpu option.
    No matter which GPU I select (I have 3) it will always render with GPU 1 (instead of GPU 0 and GPU 2). I have left my followers as 'Auto' and tried manually selecting the main's GPU but it still renders on the one GPU.

    Anybody had similar issues?

  6. #6

    Default

    I didn't really pay attention to your original post as much as I should have back when this thread was created.

    If you have a different GPU powering each monitor, then you really need to have each monitor have it's own reset region. The Reset region will, other than set the game resolution, will also determine which GPU will render the game. So if you have set region 1 as the Reset region for swap group 2, then pretty much everything will render on that GPU.

    so, if you still want to go down that path of having all the game render at the same resolution as Region 1, you need to duplicate region 1, move that over to the same monitor as swap group to, poke that region into swap group two as well, and set it to be the reset region for swap group two. Basically an unused region, except to determine resolution, and were putting it in swap group 2 to make sure swap group 1 doesn't get funny idea's about swapping.

    Effectively, Option 2 in my original post.

  7. #7
    Multiboxologist MiRai's Avatar
    Join Date
    Apr 2009
    Location
    Winter Is Coming
    Posts
    6352

    Default

    Other than a potential user configuration error on your end...

    1) When I tested this a few months ago, splitting the load didn't work with DX12
    2) I noticed there may have been an issue with same-name GPUs, which was resolved after renaming my GPUs in the registry

    In theory, setting the GPU assignment to "Auto Detect" and changing the display drop-down should be enough (in addition to matching those settings in your Window Layout). Maybe I'll test this again later today if I remember and have the time.
    Do not send me a PM if what you want to talk about isn't absolutely private.
    Ask your questions on the forum where others can also benefit from the information.

    Author of the almost unknown and heavily neglected blog: Multiboxology

  8. #8
    Multiboxologist MiRai's Avatar
    Join Date
    Apr 2009
    Location
    Winter Is Coming
    Posts
    6352

    Default

    I've confirmed that the issue with the game client and same-name GPUs still occurs, and so you'd need to...

    1) In the Device Manager, look at the Details tab of the GPU to get its Driver Key
    2) Go into the registry and search for that value (it should lead you to HKLM\SYSTEM\ControlSet001\Enum\PCI\{Device Instance Path} on W10)
    3) Adjust the DeviceDesc of the GPU and give it a unique designator so that it has a unique name (e.g. add a "1" or "2" at end of whatever is stored in that key)
    4) Repeat steps 1-3 for each GPU you have

    After finishing all of that, you will need to restart your computer before those changes are picked up by the game client, and, as always, messing around with the registry can screw things up, so good luck. I'll be doing this again later today so that I can submit a bug report to Blizzard, so maybe I'll have a more detailed guide today or tomorrow.

    Additional Information:

    1) You will need to have a proper Window Layout (you already know this)
    2) You will have to adjust which monitor is assigned in the video settings for any game client not assigned to the Primary display (numbers may be wrong in the WoW client, so try all available options while monitoring hardware - Monitor 1 and Monitor 2 were reversed for me)
    3) You can leave the in-game GPU assignment set to Auto Detect and WoW will assign it to the proper GPU as long as the Monitor drop-down is properly assigned
    4) Changes to either the Monitor or GPU drop-downs require a complete restart of the game client to take effect
    5) This does not work for DX12, only DX11

    EDIT1: Honestly, now that I'm trying to do a guide for this I can't replicate the issue. -__-
    EDIT2: Yep, no idea. I even did a clean reinstall of the driver to wipe everything thinking that I screwed something up trying to manually revert the changes I made, but no dice—I cannot replicate the issue, and I am having no problem splitting the load between two GPUs on two different displays in DX11.
    Last edited by MiRai : 09-24-2018 at 08:30 PM
    Do not send me a PM if what you want to talk about isn't absolutely private.
    Ask your questions on the forum where others can also benefit from the information.

    Author of the almost unknown and heavily neglected blog: Multiboxology

  9. #9

    Default

    GOD DAMNIT MIRAI WHAT YOU TOLD ME TO DO BROKE MY COMPUTER AND LUCKILY SOMEONE FROM MICROSOFT CALLED ME UP AROUND THE SAME TIME AND SAID THEY CAN FIX IT FOR ME IF I GAVE THEM MY CREDIT CARD WHICH I DID AND THEN THEY DIDNT FIX MY COMPUTER AND NOW I AM POSTING FROM MY IPHONE

    I'm actually really glad you took the time to do some investigating yourself; otherwise i'd have never really known what to do. You are right in that it seems the WoW client just didn't change GPU until we gave it a 'unique name'. I'm too chicken to try and revert the changes to see if it 'bugs' out again-- I'm happy it's working

    Sincerest thanks! =]

    *edit*
    I had to use DDU in order for the problem to manifest itself again. I didn't wipe anything from the registry previously. Installing new drivers or using the nvidia 'perform clean installation' apparently didn't affect much. Completely forgot about this tweak.
    Last edited by Kayley : 10-19-2018 at 12:01 PM

  10. #10

    Default

    Hello again!

    Have we found a way to spread the GPU load in DX12?
    I have tried a few things but nothing works as of yet. Hoping some of the smarter users may have figured it out

    Don't really wanna buy that Titan RTX.

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •