Close
Page 1 of 2 1 2 LastLast
Showing results 1 to 10 of 11
  1. #1

    Exclamation Forced WoW to load all available addons

    First of all, I'm a noob in this software so please do tell me where to look and what to look if I miss anything.

    Problem:
    When using ISBoxer to launch WoW, all available addons are loaded, even if they are disabled using default addons menu. But if I launch the clients manually, none of my five accounts have any problem enabling / disabling addons using the default menu.

    Investigation:
    1. ISBoxer already virtualizes the configs.wtf file and account names are correctly filled up.
    2. I was told to even virtualize addons.txt but I never see any 'virtualized file' appeared in the game folder (as they have different names.)
    3. I already tried to only include one character in the team, but still, all available addons even disabled are enabled.
    4. Now I try to disable them by an in-game addon called Addons Control Panel (ACP) without success.
    5. Then, I logout and disabled addons in the Options menu and get back in. Strangely, the addons are now disabled.
    6. Okay, so I exit the game properly using in-game menu, and then launch the game by ISBoxer again. After logging in, all addons are enabled in the Options menu.
    7. To check whether settings are saved successfully, I exit the game and then launch it manually. Addons are enabled / disabled properly.

    This proves that settings ARE THERE, but somehow ISBoxer doesn't read them.

    Anyone had this problem before? Anyone know what I can do?

  2. #2

    Default

    Delete your addons.txt virtual file? ISBoxer doesn't virtualize addons.txt by default or even mess in any way with your addons or which of them are enabled.

    The only difference from running normal WoW should be that Inner Space is running with Administrator permissions, and therefore so is the game. If you're on Vista or Windows 7, and have the game installed to your Program Files folder -- or "Program Files (x86)" -- that means the OS may be virtualizing the file system automatically when not running through IS, and putting the actual addons.txt under something like C:\Users\<name>\AppData\Local\VirtualStore\Program Files\World of Warcraft\. When you run it through IS, with Admin permissions, Windows will NOT put it there.

    If this doesn't help, show me your config so I can see what you were doing to addons.txt
    Lax
    Author of ISBoxer
    Video: ISBoxer Quick Start

  3. #3

    Default

    I'm sorry about this belated reply but RL's been quite busy.

    I think I kinda figured out what's happening. As I want to play with some of my RL friends, I actually used ENUS Warcraft client to play on Taiwan servers. Now, CONFIG.WTF is stored at \WTF\ which is fine but AddOns.txt is stored at \WTF\Account\Account Name\Server Name\Character Name\

    The point is Server Name is in Chinese! And I guess ISBoxer is not programmed to read that? I tend to believe this theory right now because it perfectly explains why addons are enabled / disabled properly without using ISBoxer, but they're all messy after using ISBoxer.

    Now, what to do...

  4. #4
    Member
    Join Date
    Sep 2008
    Location
    Calgary, AB and Vancouver, BC
    Posts
    7639
    Blog Entries
    2

    Default

    Well, if you don't mind redoing your configuration, etc., you could delete your entire WTF folder.

    You could also go into the correct version/location for each of the addons, and save the respective configuration file, then delete the WTF, run the addons again, and paste the backed up saved variables.

    There's probably a better method, but that's what I've got so far.
    EverQuest I: Bard / Enchanter / Druid / Wizard / 2x Magician.
    Diablo III: 4x Crusader & 4x Wizard.

    My Guide to IS Boxer http://www.dual-boxing.com/showthread.php?t=26231 (somewhat dated).
    Streaming in 1080p HD: www.twitch.tv/ualaa
    Twitter: @Ualaa


  5. #5

    Default

    I'm sorry but I don't understand what your suggestion's for... because every single addon is still enabled.

    I could possibly solve my problem by duplicating the entire WoW folder five times and then delete addons that I don't want for each account. But then, I need to manually update these addons whenever they break, which will be catastrophic.

    I really hope Lax could shed some light on my problem.

    Cheers.

  6. #6

    Default

    konraddo, I know and had these problems when I first began. Here is what you must do:

    1. login to your accounts using innerspace
    2. turn off repeating and mappings while working on the addons
    3. use the wow character screen addons button to enter and turn on or off per character
    4. login to each of your characters and setup each addon as you want them to react
    5. logout using the /logout command or using the esc key and logout
    6. then logout of the game

    You must do this for each of your toons and each of your accounts will save the settings correctly.

    After setting each up that way when you reload using innerspace your settings should be exactly as you left them.
    Last edited by sonic777 : 10-03-2010 at 02:12 PM

  7. #7

    Default

    Turning off repeating and mappings means clicking the two little icons on the top left corner, right? They're both disabled when I did the test, but unfortunately your suggestion doesn't work.

    I further investigated and tried to prove my theory about ISBoxer not reading folder names with non-English characters. I logged in without using ISBoxer and moved the chat window, changed some color settings etc. I logged out and relogged in and the changes were all there. Then I launched the game via ISBoxer, and chat window was in default position and there's no change whatsoever.

    Any more help?

  8. #8

    Default

    Umm I'll check on the server names issue. ISBoxer Toolkit wouldn't have any problem with that, but it's entirely possible there's a related bug in Inner Space.
    Lax
    Author of ISBoxer
    Video: ISBoxer Quick Start

  9. #9

    Default

    Yup, Chinese server names are correctly displayed in ISBoxer Suite.

  10. #10

    Default

    So... any news to my problem? Or do I need to play 4.0.1 without the wonderful ISBoxer? >_<

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •