Close
Page 1 of 2 1 2 LastLast
Showing results 1 to 10 of 13
  1. #1

    Default Win7 CPU "Parking"

    My performance was absolutely horrible last night so I popped open Performance Monitor. I noticed that two of my physical cores were running at 100% and the other two physical cores had a "Parked" status.

    So it turns out that Windows 7 parks cores to save on power. Not sure how it decides whether to park cores or not but WoW was unplayable.

    I found the following thread with details on how to disable core parking, requires registry changes, use at your own risk:
    http://forum.cakewalk.com/tm.aspx?m=1861804

    I am using KeyClone and all 4 physical cores are selected for the CPU affinity but I still got cores parked.
    The Orcks of War
    Shaman Borck Zorck Dorck Porck Corck
    Mixed Team - Msblonde - Mswhite - Msblack - Msred - Msbrown -

  2. #2

    Default

    Make sure you have cpu affinity properly set in your config files. I've never had an issue with ''parking''.
    Last edited by Sajuuk : 12-09-2009 at 05:16 PM
    Hardware Lurker

  3. #3

    Default

    Very strange. I have Win7 here on a Q9550 at work and I never see a core go into "parked" mode, even though the value was set to 100% parking available. I work in OS Test here. Lemme see if I can find out some more about this as I'm sure there are certain caveats to default versus disabled.
    Now playing: WoW (Garona)

  4. #4

    Default

    According to Microsoft it depends on power settings. If you select the "high performance" plan, parking doesn't happen.

    I.e. parking is a power-saving feature.

    I haven't tested this ... it's just what I've read.
    �Author of HotkeyNet and Mojo

  5. #5

    Default

    Quote Originally Posted by Freddie View Post
    According to Microsoft it depends on power settings. If you select the "high performance" plan, parking doesn't happen.

    I.e. parking is a power-saving feature.

    I haven't tested this ... it's just what I've read.
    I read that as well and checked my power settings, it was set to "High Performance" which should have core parking disabled.
    The Orcks of War
    Shaman Borck Zorck Dorck Porck Corck
    Mixed Team - Msblonde - Mswhite - Msblack - Msred - Msbrown -

  6. #6
    Member
    Join Date
    Sep 2008
    Location
    Calgary, AB and Vancouver, BC
    Posts
    7606
    Blog Entries
    2

    Default

    Maybe Win7 is like Vista, in that the power settings you pick mean nothing at all, unless you make a registry change.
    EverQuest I: Bard / Enchanter / Druid / Wizard / 2x Magician.
    Diablo III: 4x Crusader & 4x Wizard.

    My Guide to IS Boxer http://www.dual-boxing.com/showthread.php?t=26231 (somewhat dated).
    Streaming in 1080p HD: www.twitch.tv/ualaa
    Twitter: @Ualaa


  7. #7

    Default

    Quote Originally Posted by thinus View Post
    I read that as well and checked my power settings, it was set to "High Performance" which should have core parking disabled.
    What about the sub-settings for "High Performance?" I think you have to press Advanced to get to them. Is parking itemized there?
    �Author of HotkeyNet and Mojo

  8. #8

    Default

    Quote Originally Posted by Freddie View Post
    What about the sub-settings for "High Performance?" I think you have to press Advanced to get to them. Is parking itemized there?
    No, it isn't. Only throttling. We're quickly getting into "I don't think that means what you think it means" territory here and I haven't found a good writeup on the basics behind the three different processor/thread optimizations that apply here vis-a-vis multiboxing performance in Dalaran. If I find one, I'll forward it along. I'd write up a quick one but I'm sleep deprived (babysitting cats this week and those bitches are NEEDY).
    Last edited by Ughmahedhurtz : 12-09-2009 at 06:50 PM
    Now playing: WoW (Garona)

  9. #9

    Default

    Interesting. I just skimmed the documentation for the Win32 API for controlling this stuff programmatically to see if the setting is there. The API is incredibly complicated.

    When I get time I'll try to add a setting to Mojo so the user can check a box and Mojo will disable parking while it's running.

    It's going to have a bunch of performance settings like that.
    �Author of HotkeyNet and Mojo

  10. #10
    Member jstanthr's Avatar
    Join Date
    Jun 2009
    Location
    Knoxville, Tennessee
    Posts
    334

    Default

    my i7 920 is doing something similar to the same thing, with ht on wow will always use only 1 core per client, but i i only open 1 client (withouth keyclone) it will use a physicall and logical (2 cores). and all my settings are on high perf wil all power saving bs off, if i wanna save power i'll turn the thing off. currently i have my affinity set as 1 (0-1), 2 (2-3), 3 (4-5), 4 (6-7), 5 (4-6) i also tried splitting them 1(0-2), 2 (1-3), 3 (4-6), 4 (5-7), 5 (4-6) and it still only uses a single core. my performance isn't bad at all im getting 60+ frames on main client (mon1) and have the slaves clipped at 25 2x2 on mon2. got all the eye candy turned on on main at 1440*900 and slaves running at 720*450 everything on lowest.
    Magtheridon US <The Zerg>
    PvE Teams (A lot funner than i expected)


    PVP-Farming teams


Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •